Suite

La symbologie des points ne s'affiche pas correctement dans la carte Web ArcGIS Online ?

La symbologie des points ne s'affiche pas correctement dans la carte Web ArcGIS Online ?


J'ai créé un service de carte (via ArcGIS Server) pour diffuser du contenu SDE jusqu'à une carte/application Web dans ArcGIS Online. Le service contient un groupe de 10 fichiers de formes (points, lignes et polygones). Toutes les données sont présentes et le service de carte fonctionne correctement lorsqu'il est ouvert dans ArcMap. Cependant, chaque fois que j'ajoute le service à une carte Web ArcGIS Online, les symboles ponctuels dessinent un décalage d'environ 60 pieds au sud-ouest (voir l'image). La boîte de sélection bleue est la vraie position du point ; notez la symbologie au SW.

Les polygones et les lignes se dessinent comme il se doit. Si j'ajoute les fichiers de formes individuels du groupe à la carte (plutôt que d'intégrer l'ensemble du service), les points se dessinent bien. En faisant cela, cependant, je perds la possibilité de grouper des calques. Toutes les données sont dans la même projection.

Une idée de ce qui se passe ?


Ce problème a été "résolu" (vraiment plus une solution de contournement) en changeant la projection/transformation du trame de données dans le service de carte vers Web Mercator (WGS84). Cela m'a permis de ne pas avoir à reprojeter les données que nous avons stockées dans un SGBD (via ArcSDE) et de toujours symboliser correctement les points dans mon application web.