Suite

Conflit QGIS 1.7.1 et PyQT4 : qu'est-ce que je fais mal ?

Conflit QGIS 1.7.1 et PyQT4 : qu'est-ce que je fais mal ?


Je viens de commencer à jouer avec QGIS en vue de développer éventuellement quelques plugins simples en Python. j'ai téléchargéQGIS 1.7.1pour Windows et commencé à travailler sur ces notes d'atelier.

Si j'ai bien compris, développer des plugins utilise souventConcepteur QTet quelque chose qui s'appellepyuic4. Ceux-ci ne semblent pas être inclus dans l'installation de QGIS, j'ai donc téléchargé PyQT4 séparément. Cela m'a permis de finir de travailler dans l'atelier, mais maintenant, lorsque je démarre QGIS, j'obtiens l'erreur suivante :

Traceback (appel le plus récent en dernier) : File "", ligne 1, dans RuntimeError : le module PyQt4.QtCore est la version 1 mais le module qgis.core nécessite la version -1

Si je désinstalle PyQT4, le problème disparaît, mais je n'ai plusConcepteur QTou alorspyuic4, alors comment développer des plugins ? je ne sais pas quoiversion 1de PyQT4 est.

Est-ce que quelqu'un a des suggestions s'il vous plaît? Je fais évidemment quelque chose de stupide, mais je ne sais pas quoi. Peut-être QT Designer est en fait inclus quelque part avec QGIS 1.7.1, mais si c'est le cas, je ne le trouve pas…

Merci!


Avez-vous installé la version OSGeo4W de QGIS ? Si vous l'avez fait, vous aurez pyuic4 disponible via la ligne de commande OSGeo.

Je n'utilise pas QT Designer mais QT Creator sur Win 7 (doit être installé séparément), peut-être que cela fait une différence.